Opened 10 years ago

Closed 9 years ago

#441 closed defect (duplicate)

Missing definition of Chroma QP

Reported by: qhuang Owned by: bbross
Priority: minor Milestone: WD6
Component: Text Version: D6 (H1003) dI/dJ/dK
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

The relationship between Luma QP and Chroma QP is borrowed from AVC in HM software. However, there is no definition in our committee draft. As a result, many usages are incorrect. Some examples are given here:

  1. The Chroma QP derivation in equations (8-255) and (8-256) are incorrect.
  2. Luma QP is incorrectly used for chroma deblocking.

Change History (3)

comment:1 Changed 10 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 10 years ago by bbross

Thanks for reporting this. Would it be possible to specify the reported issues?

  1. "The Chroma QP derivation in equations (8-255) and (8-256) are incorrect."

Which definition is missing exactly?
Looking at the draft, this should be the AVC table: "Specification of QPC as a function of qPI" and change equations 8-255 and 8-256 as follows.
qPICb = Clip3( −QpBdOffsetC, 51, QPY + cb_qp_offset) (8 255)
qPICr = Clip3( −QpBdOffsetC, 51, QPY + cr_qp_offset) (8 256)
QP’Cb = QPCb + QpBdOffsetC (8 257)
QP’Cr = QPCr + QpBdOffsetC (8 258)

  1. "Luma QP is incorrectly used for chroma deblocking."

Is this related to the following items from the H1003 open issues list?

  • The variable qPL used in deblocking filter process has to be defined by, e.g. setting it to QPY.
  • The Chroma QP should be considered in chroma edge filtering instad of luma QP.
  • The tc and beta values of the deblocking filter should be explicitly scaled in the text since their values are provided in the table for the 8-bit case.
  1. "As a result, many usages are incorrect."

What else is broken except chroma deblocking?

comment:3 Changed 9 years ago by bbross

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #492.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Qian Huang(Reporter)
  • Woo-Jin Han(Subscriber)