Opened 10 years ago

Closed 9 years ago

#437 closed enhancement (fixed)

Split flag conditions

Reported by: rkaliski Owned by: bbross
Priority: minor Milestone:
Component: Text Version: D6 (H1003) dI/dJ/dK
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

For WD H1003 Rev K (21):

In section 7.4.5 Coding tree semantics,

for split_coding_unit_flag, mention the boundary CUs (LCUs) which traverse the picture boundary on the right or bottom are processed as if a split flag were present, inferred.

Change History (4)

comment:1 Changed 10 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 10 years ago by bbross

Thanks for the report but I am not sure whether I understand the issue that is being reported.

When a coding tree block (CTB) crosses picture boundary, it is split into smaller coding blocks (CBs) until an integer number of coding blocks fits the picture boundaries. This split is not signaled as controlled by the conditions in the coding tree syntax:

if(
(x0+(1<<log2CbSize)<=pic_width_in_luma_samples) &&
(y0+(1<<log2CbSize)<=pic_height_in_luma_samples) &&
(MinCbAddrZS[x0>>Log2MinCbSize][y0>>Log2MinCbSize]>=SliceCbAddrZS) &&
(log2CbSize>Log2MinCbSize) &&
(NumPCMBlock==0)
)

split_coding_unit_flag[ x0 ][ y0 ]

In case this split flag is not signaled and the minimum allowed CB size is not reached, split_coding_unit_flag is inferred to be 1 in the semantics which results in splitting until the CBs in a CTB fits the boundaries.

Thus the case of CTBs over picture boundaries is taken care of. When this is not the issue or I have overseen something, an example showing where the problem is would help to understand it.

comment:3 Changed 10 years ago by bbross

  • Version set to D6 (H1003) dI/dJ/dK

comment:4 Changed 9 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Raffi(Reporter)
  • Woo-Jin Han(Subscriber)