Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#430 closed defect (fixed)

SliceMode = 2 bug

Reported by: shilin.xu Owned by:
Priority: minor Milestone: HM-6.1
Component: HM Version: HM-6.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

When sliceMode = 2, the encoder seems to encode the last LCU of a tile for multiple times to achieve the bytes limit. This will result in two issues: 1) multiple slices are generated at the position of the last LCU of a tile. 2) the encoder runs much slower than normal. I suspect this issue is related to the code associated with "COMPLETE_SLICES_IN_TILE" macro.

Attachments (1)

Fix430_r2147.patch (1.2 KB) - added by Tammy 10 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 10 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

Changed 10 years ago by Tammy

comment:2 Changed 10 years ago by Tammy

The issue is related with the code 'COMPLETE_SLICES_IN_TILE'. NextSlice is not set properly with SliceMode=2 when a tile boundary is met. The patch is provided based on HM6.0-dev r2147.

comment:3 Changed 10 years ago by ksuehring

  • Resolution set to fixed
  • Status changed from new to closed

The patch has been applied in r2150

comment:4 Changed 10 years ago by ksuehring

  • Milestone set to HM-6.1
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Shilin Xu(Reporter)
  • Tammy(Participant)