Opened 10 years ago

Closed 9 years ago

#233 closed defect (fixed)

[WD4] Issue in specification of Intra_Angular prediction mode

Reported by: tkunlin Owned by: wjhan
Priority: minor Milestone:
Component: Text Version: WD4 (F803) d6
Keywords: Cc: jct-vc@…

Description

The current WD4 does not describe the intra angular prediction properly for IntraPredOrder greater than or equal to 18. In that case, the predictor obtained is a transposition of the expected result.

Find attached a proposed revision of the Intra_Angular prediction mode specification (starting after the invAngle table).

Attachments (2)

intra_angular_prediction.txt (2.0 KB) - added by tkunlin 10 years ago.
233_dG.zip (61.8 KB) - added by wjhan 9 years ago.
Fix based on D6 dG

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by tkunlin

comment:1 Changed 9 years ago by bbross

  • Version changed from HM-4.1 to WD4 d6

comment:2 Changed 9 years ago by davidf

  • Cc jct-vc@… added

comment:3 Changed 9 years ago by bbross

  • Owner changed from bbross to wjhan
  • Status changed from new to assigned

comment:4 Changed 9 years ago by wjhan

Confirmed. And due to adoption of H0407 (logical mode numbering), "less than 18" should replaced by "equal or greater than 18" additionally.

Attached file is the fix based on D6 dG. According to the software behavior, I added "swapped process for horizontal-like directions" on top of current text.

Changed 9 years ago by wjhan

Fix based on D6 dG

comment:5 Changed 9 years ago by bbross

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in D6 (H1003) dI

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Participant)
  • David Flynn(Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Thomas Kunlin(Reporter)
  • Woo-Jin Han(Owner, Participant)