Opened 11 years ago

Closed 11 years ago

#2 closed defect (worksforme)

The software fails when encoding

Reported by: anonymous Owned by: davidf
Priority: minor Milestone:
Component: HM Version:
Keywords: Cc: davidf, hurumi@…, fbossen, ksuehring, jct-vc@…

Description

Encoding 832x480 sequence, using the command line below, after encoding POC 38, the software will fail.

-c ./cfg/RaceHorsesC.cfg -ip 32 -f 96 -g 8 -r 4 -rb0 2 -rb1 2 -s 128 -h 5 -q 32 -t 8 -ltd 0 -utd 1 -1 FEN

Attachments (1)

RaceHorses_832x480_30_MaxTr_8_32.log (5.7 KB) - added by anonymous 11 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 11 years ago by davidf

  • Owner set to davidf
  • Status changed from new to assigned

I have been unable to reproduce the issue. The encode completed for me without error (see below). Are you able provide a log of the encode?

$ ~/project/build/jctvc-a124-amd64/jctvc-a124-enc -c ~/project/jctvc-a124/cfg/cfp/cfg/RaceHorsesC.cfg -ip 32 -f 96 -g 8 -r 4 -rb0 2 -rb1 2 -s 128 -h 5 -q 32 -t 8 -ltd 0 -utd 1 -1 FEN -i /project/hvc/anchors/RaceHorses_832x480_30.yuv

TMuC SW candidate: Encoder Version [0.1][Linux][GCC 4.5.1][64 bit]

...
POC   34 ( B-SLICE, QP 35 )      21632 bits [Y 31.7250 dB    U 36.9214 dB    V 38.1342 dB]  [ET    55 ] [L0 32 30 ] [L1 36 40 ]
POC   38 ( B-SLICE, QP 35 )      18632 bits [Y 31.9794 dB    U 37.3608 dB    V 38.3262 dB]  [ET    34 ] [L0 36 34 ] [L1 40 36 ]
POC   33 ( B-SLICE, QP 36 )       9256 bits [Y 31.4215 dB    U 36.8232 dB    V 38.0069 dB]  [ET    27 ] [L0 32 30 ] [L1 34 36 ]
...

comment:2 Changed 11 years ago by anonymous

My log is as below

TMuC SW candidate: Encoder Version [0.1][Windows][VS 1600][64 bit]

...
POC 34 ( B-SLICE, QP 35 ) 21840 bits [Y 31.7093 dB U 36.9497 dB V 38.1170 dB] [ET 75 ] [L0 32 30 ] [L1 36 40 ]
POC 38 ( B-SLICE, QP 35 ) 18992 bits [Y 31.9933 dB U 37.5095 dB V 38.4196 dB] [ET 53 ] [L0 36 34 ] [L1 40 36 ]

and the software ends, no more information.

BTW, the encoding results are not exactly the same.

comment:3 Changed 11 years ago by anonymous

BTW, other QP, such as 22, 27, 37, and other 832x480 sequence also fails.

comment:4 Changed 11 years ago by davidf

Please could you provide the full encoder log. Does the encoder crash with an windows exception, if so, what exception?

Please could you check that the md5sum of the source video is:

0a351df99f22d837bc528bd4901c6968 *RaceHorses_832x480_30.yuv

comment:5 in reply to: ↑ description Changed 11 years ago by wjhan

  • Cc hurumi@… added

Replying to anonymous:

Encoding 832x480 sequence, using the command line below, after encoding POC 38, the software will fail.

-c ./cfg/RaceHorsesC.cfg -ip 32 -f 96 -g 8 -r 4 -rb0 2 -rb1 2 -s 128 -h 5 -q 32 -t 8 -ltd 0 -utd 1 -1 FEN

I guess that '-t 8' (max allowable transform size) can be the problem source. Original A124 supports this feature (large block size, small transform size) when LOT (logical transform) is turned on, however, during the stripping stage from A124 to TMuC code-base, LOT was removed and now '-t' option is not working for intra mode. But I'm not fully sure since the crash occurs after encoding several slices.

Could you please check it without '-t 8' option?

By the way, if you really want to test the small transform size while keeping large block size, quadtree TU tool by HHI may be useful for that purpose. The following is a part of the configuration file from the recently integrated software.

QuadtreeTUFlag : 1
# Use quadtree-based TU coding

QuadtreeTULog2MaxSize : 6
# Log2 of maximum transform size for quadtree-based TU coding (2...6)

QuadtreeTULog2MinSize : 2
# Log2 of minimum transform size for quadtree-based TU coding (2...6)

I guess that QuadtreeTULog2MaxSize should be equal to 3 to limit the maximum transform size to 8. For the integrated software, I belive that David will apply the latest changes to the source repository soon.

Changed 11 years ago by anonymous

comment:6 Changed 11 years ago by anonymous

Thanks for all your help. I have tried other max transform sizes, all are OK.
The md5sum of my source video is correct. The encoder crash without any useful windows exception. And I have uploaded my full log file.

comment:7 Changed 11 years ago by davidf

  • Resolution set to worksforme
  • Status changed from assigned to closed

I have not been able to reproduce this bug. Please can you retry with a newer version of the encoder. Several memory leak issues have since been fixed that might have been causing this problem.

comment:8 Changed 10 years ago by davidf

  • Component set to HM

Updating component after adding WD (Text) tickets

comment:9 Changed 10 years ago by davidf

  • Cc davidf added; hurumi@… removed

comment:10 Changed 10 years ago by davidf

  • Cc hurumi@… added

comment:11 Changed 10 years ago by davidf

  • Cc fbossen ksuehring added

comment:12 Changed 10 years ago by davidf

  • Cc jct-vc@… added
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Owner, Subscriber, Participant)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Always)
  • Woo-Jin Han(Subscriber, Participant)