Opened 9 years ago

Closed 9 years ago

#1 closed defect (wontfix)

GOP size issues

Reported by: anonymous Owned by:
Priority: major Milestone:
Component: HM Version:
Keywords: Cc: dong.tian@…, davidf@…, hurumi@…, fbossen, ksuehring, davidf, jct-vc@…

Description

When the GOP size is 12 instead of 8, the encoder and decoder do not crash, but have mismatches for frames: 1, 13, 25, 37, which are just the first frame of a GOP in display order.

Change History (9)

comment:1 Changed 9 years ago by davidf

  • Cc davidf@… added

comment:2 Changed 9 years ago by anonymous

I would withdraw this ticket. Seems it is not a problem of GOP size, but some other issues not identified yet that may be related to the NumOfReference. Sorry for the confusions.

comment:3 in reply to: ↑ description ; follow-up: Changed 9 years ago by wjhan

  • Cc hurumi@… added

Replying to anonymous:

When the GOP size is 12 instead of 8, the encoder and decoder do not crash, but have mismatches for frames: 1, 13, 25, 37, which are just the first frame of a GOP in display order.

GOP size is designed to specify the pyramid temporal structure of hierarchical-B structure. Currently, encoder is implemented with assuming the dyadic pyramid, thus GOP size should be a power of 2, e.g. 1, 2, 4, 8, so on.

Non-pyramidal coding (e.g. IBBP) or non-dyadic pyramidal coding can be easily supported by similar fashion to JM. Maybe this kind of functional improvements can be done after some major integration works are finished according to the suitable approval from the SW AhG.

comment:4 in reply to: ↑ 3 ; follow-up: Changed 9 years ago by anonymous

Thank you for your reply. After more careful checking, I do not find problem with GOP size 12. However, it seems the problem is from the settings of the number of references. If all are set to 1 as below, we can observe the encoder /decoder mismatch.

NumOfReference : 1
NumOfReferenceB_L0 : 1
NumOfReferenceB_L1 : 1
GopSize : 12

However, there is no problem with,

NumOfReference : 4
NumOfReferenceB_L0 : 2
NumOfReferenceB_L1 : 2
GOPSize : 12

Maybe it derserve to look into the reason at a proper time. Thanks!

Replying to wjhan:

Replying to anonymous:

When the GOP size is 12 instead of 8, the encoder and decoder do not crash, but have mismatches for frames: 1, 13, 25, 37, which are just the first frame of a GOP in display order.

GOP size is designed to specify the pyramid temporal structure of hierarchical-B structure. Currently, encoder is implemented with assuming the dyadic pyramid, thus GOP size should be a power of 2, e.g. 1, 2, 4, 8, so on.

Non-pyramidal coding (e.g. IBBP) or non-dyadic pyramidal coding can be easily supported by similar fashion to JM. Maybe this kind of functional improvements can be done after some major integration works are finished according to the suitable approval from the SW AhG.

comment:5 in reply to: ↑ 4 Changed 9 years ago by wjhan

Replying to anonymous:

Thank you for your reply. After more careful checking, I do not find problem with GOP size 12. However, it seems the problem is from the settings of the number of references. If all are set to 1 as below, we can observe the encoder /decoder mismatch.

NumOfReference : 1
NumOfReferenceB_L0 : 1
NumOfReferenceB_L1 : 1
GopSize : 12

However, there is no problem with,

NumOfReference : 4
NumOfReferenceB_L0 : 2
NumOfReferenceB_L1 : 2
GOPSize : 12

Maybe it derserve to look into the reason at a proper time. Thanks!

Replying to wjhan:

Replying to anonymous:

When the GOP size is 12 instead of 8, the encoder and decoder do not crash, but have mismatches for frames: 1, 13, 25, 37, which are just the first frame of a GOP in display order.

GOP size is designed to specify the pyramid temporal structure of hierarchical-B structure. Currently, encoder is implemented with assuming the dyadic pyramid, thus GOP size should be a power of 2, e.g. 1, 2, 4, 8, so on.

Non-pyramidal coding (e.g. IBBP) or non-dyadic pyramidal coding can be easily supported by similar fashion to JM. Maybe this kind of functional improvements can be done after some major integration works are finished according to the suitable approval from the SW AhG.

Thanks for the nice information! We will investigate the problem and try to apply the patch at the proper time.

comment:6 Changed 9 years ago by davidf

  • Resolution set to wontfix
  • Status changed from new to closed

comment:7 Changed 8 years ago by davidf

  • Component set to HM

Updating component after adding WD (Text) tickets

comment:8 Changed 8 years ago by davidf

  • Cc fbossen ksuehring davidf added

comment:9 Changed 8 years ago by davidf

  • Cc jct-vc@… added
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber, Participant)
  • davidf@…(Subscriber)
  • dong.tian@…(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • Karl Sharman(Always)
  • Karsten Suehring(Subscriber, Always)
  • Woo-Jin Han(Subscriber, Participant)