Opened 3 years ago

Closed 11 months ago

#1489 closed technical change (invalid)

rangeTabLps error?

Reported by: shakingWaves Owned by:
Priority: critical Milestone: v5
Component: Text Version: v4 (12/2016)
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

Table rangeTabLps which was corresponding to Table 9-46 in standard specification, lists all lps range of every state.
But, rangeTabLps still exists "interval inversion" problem, that is, the subinterval for the MPS may be smaller than the subinterval for the LPS.
for example:

pStateIdx equals to 1 and qRangeIdx equals to 2, and lps symbol occurs,
then m_uiRange equals to 167 which was smaller than 256, so m_uiRange = (m_uiRange << 1) = 334,
because of lps symbol, the pStateIdx will translate to 0 and
uiLPS = TComCABACTables::sm_aucLPSTable[0][ ( 334 >> 6 ) & 3 ] = 176,
so, mps_range = m_uiRange - uiLPS = 334 - 176 = 158,
which will cause mps_range < lps_range, that is a bug?

Change History (3)

comment:1 Changed 3 years ago by bbross

Ticket #1488 has been marked as a duplicate of this ticket.

comment:2 Changed 11 months ago by crosewarne

The example in the ticket is believed to be incorrect as the steps do not match Figure 9-6 (Flowchart for decoding a decision). In particular, the renormalization should be the last step and hence the example should begin with already renormalized inputs.

comment:3 Changed 11 months ago by crosewarne

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Li Xiaobo(Reporter)
  • Woo-Jin Han(Subscriber)