Opened 3 years ago

Closed 2 years ago

#1488 closed defect (duplicate)

rangeTabLps

Reported by: shakingWaves Owned by:
Priority: minor Milestone:
Component: Text Version: v3 (04/2015)
Keywords: rangeTabLps Cc: bbross, wjhan, jct-vc@…

Description

Table rangeTabLps which was corresponding to Table 9-46 in standard specification, lists all lps range of every state.
But, rangeTabLps still exists "interval inversion" problem, that is, the subinterval for the MPS may be smaller than the subinterval for the LPS.
for example:

pStateIdx equals to 1 and qRangeIdx equals to 2, and lps symbol occurs,
then m_uiRange equals to 167 which was smaller than 256, so m_uiRange = (m_uiRange << 1) = 334,


because of lps symbol, the pStateIdx will translate to 0 and
uiLPS = TComCABACTables::sm_aucLPSTable[0][ ( 334 >> 6 ) & 3 ] = 176,
so, mps_range = m_uiRange - uiLPS = 334 - 176 = 158,
which will cause mps_range < lps_range, that is a bug?

Change History (1)

comment:1 Changed 2 years ago by bbross

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #1489.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Li Xiaobo(Reporter)
  • Woo-Jin Han(Subscriber)