Opened 7 years ago

Closed 7 years ago

#1279 closed defect (duplicate)

Frame level PSNR for interlaced sequence.

Reported by: Mrigen Owned by: ksuehring
Priority: minor Milestone: HM-16.2
Component: HM Version: HM-14.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

Function: xCalculateInterlacedAddPSNR
Issue: Wrong frame size(iSize).

Probable Fix:
change

Int iSize = iWidth*iHeight;

To

Int iSize = iWidth*(iHeight<<1);

Change History (6)

comment:1 Changed 7 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 7 years ago by Mrigen

Correct fix would be
Change from

iHeight = pcPicOrgTop->getPicYuvOrg()->getHeight() - m_pcEncTop->getPad(1);
Int iSize = iWidth*iHeight;


To

iHeight = pcPicOrgTop->getPicYuvOrg()->getHeight() - (m_pcEncTop->getPad(1)>>isField);
Int iSize = iWidth*iHeight;

Last edited 7 years ago by Mrigen (previous) (diff)

comment:3 Changed 7 years ago by ksuehring

  • Milestone HM-15.0 deleted

comment:4 Changed 7 years ago by barrouxg

I am unclear what error you are trying to show here.

Your first proposal of change would indicate that you think the iSize should be the full frame size. Now, the PSNR computation is done on one field after another and therefore needs the field iSize.

Your second proposal of change would indicate that you think only the padding was not well computed. In this case this is a duplicate of the ticket 1278.

I think we can close this ticket and apply the patch found for the ticket 1278.

comment:5 Changed 7 years ago by ksuehring

  • Milestone set to HM-16.2
  • Owner set to ksuehring
  • Status changed from new to assigned

comment:6 Changed 7 years ago by ksuehring

  • Resolution set to duplicate
  • Status changed from assigned to closed

Closed as duplicate of #1278.
closing as duplicate

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • Guillaume(Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Owner, Subscriber, Participant, Always)
  • Mrigendra Nagar(Reporter, Participant)