Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1278 closed defect (fixed)

PSNR for fields

Reported by: Mrigen Owned by: ksuehring
Priority: minor Milestone: HM-16.2
Component: HM Version: HM-14.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

It seems PSNR data is not collected properly in HM14.0

Function: xCalculateAddPSNR
Input resolution: 1920x1080
isinterlaced : Yes

Issue:
iHeight value comes as 536 in place of 540.

Attachments (1)

fix_1278.patch (1.6 KB) - added by barrouxg 6 years ago.
This patch fixes the padding problem for field size computation when computing the PSNR values.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 6 years ago by ksuehring

  • Milestone HM-15.0 deleted

Changed 6 years ago by barrouxg

This patch fixes the padding problem for field size computation when computing the PSNR values.

comment:3 Changed 6 years ago by barrouxg

I attached a patch that uses the same solution as the second one proposed for the ticket 1279.

The pad value is multiplied by two before being saved to represent the one of the full frame size. In the function where it was used it was not divided by 2 before being applied to the field size computation, hence the noted issue. My code simply applies this division by two for the padding value.

The patch also corrects the same problem in xCalculateInterlacedAddPSNR

comment:4 Changed 6 years ago by ksuehring

  • Milestone set to HM-16.2
  • Owner set to ksuehring
  • Status changed from new to assigned

comment:5 Changed 6 years ago by ksuehring

  • Resolution set to fixed
  • Status changed from assigned to closed

the patch has been applied in r4131

comment:6 Changed 6 years ago by ksuehring

Ticket #1279 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • Guillaume(Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Owner, Subscriber, Participant, Always)
  • Mrigendra Nagar(Reporter)