Opened 8 years ago

Closed 8 years ago

#1266 closed defect (duplicate)

C++ istream EOF exception not thrown on OS X 10.9

Reported by: fabianjaeger Owned by:
Priority: minor Milestone: HM-13.0
Component: HM Version: HM-13.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

When decoding a bitstream on OS X 10.9 with HTM 13.0, the decoder does not terminate as it cannot determine the EOF of the input file stream.
The decoder binary is built using the unmodified Xcode project file from the SVN repository.

The reason seems to be the libc++ used by the LLVM compiler on OSX 10.9, which does not throw an exception in case of EOF during a read operation on an istream. This behavior can be changed by applying the attached patch.

Attachments (1)

llvm_istream.patch (436 bytes) - added by fabianjaeger 8 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

Changed 8 years ago by fabianjaeger

comment:2 Changed 8 years ago by fabianjaeger

I meant "HM" instead of "HTM" in the ticket description, of course.

comment:3 Changed 8 years ago by fbossen

Sounds like a duplicate of #1233

comment:4 Changed 8 years ago by fabianjaeger

Yes, you are right. This is obviously a duplicate and can therefore be closed. Thanks.

comment:5 Changed 8 years ago by fabianjaeger

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #1233.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Fabian Jäger(Reporter, Participant)
  • Frank Bossen(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Always)