Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1233 closed defect (fixed)

HM decoder hang under Mac OSX 10.9

Reported by: zyf674 Owned by:
Priority: blocker Milestone: HM-14.0
Component: HM Version: HM-13.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

HM decoder always hangs at the end of the bitstream if the decoder is compiled under Mac OSX 10.9 & Xcode 5.0.

Seems because of different behaviors of <istream> header files in OSX 10.9 and previous versions.

Change History (3)

comment:1 Changed 7 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 7 years ago by ksuehring

  • Resolution set to fixed
  • Status changed from new to closed

It seems to be necessary to also set std::istream::bad bit to the list of exceptions to make get() fail.

Fix committed in r3839

comment:3 Changed 7 years ago by fabianjaeger

Ticket #1266 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Fabian Jäger(Participant)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Yifu Zhang(Reporter)