Opened 7 years ago

Closed 7 years ago

#1242 closed defect (duplicate)

Issues due to strict compile checking - HM11.0

Reported by: elenva Owned by: N Vijay Anand
Priority: minor Milestone:
Component: HM Version: HM-11.0
Keywords: Cc: nvijay.anand@…, fbossen, ksuehring, davidf, jct-vc@…

Description

Im using HM11.0 release version. I've used strict compile settings and see
decoder crashes. I'm using arm-xilinx-linux-gnueabi-g++ (Sourcery CodeBench Lite 2012.09-104) 4.7.2 compiler.

  1. Line #391, TComRom.cpp file

" UInt log2Blk = g_aucConvertToBit[ uiNumBlkSide ] + 1;"

The array g_aucConvertToBit is of type Char and initialised to -1.
Desired value in log2Blk is 0, but compiler is putting 256.
Changing UInt log2Blk to UChar log2Blk fixes the issue.

  1. In file TComMotionInfo.h, class TComMvField {

private:

TComMv m_acMv;
Int m_iRefIdx;

...

}

Same issue with parameter m_iRefIdx. Somewhere in code it's initialised by -1, but
value returned when queried is 255.
Changing m_iRefIdx from Int to Char recursively in code fixes the issue.

  1. I think there are host of other clean compilation issues, but they aren't causing crashes.

Thanks,
Vijay

Change History (3)

comment:1 Changed 7 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 7 years ago by ksuehring

The problem is that char is unsigned by default on ARM. The following code has been added in Typedef.h in HM 13.0 to avoid such issues based on ticket #206.

#ifdef __arm__
typedef       signed char         Char;
#else
typedef       char                Char;
#endif

We do no fix old releases. Please test with HM 13.0.

comment:3 Changed 7 years ago by ksuehring

  • Milestone HM-14.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #206.
Closing. Please reopen, if you still have problems.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • N Vijay Anand(Reporter, Subscriber)