Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1240 closed defect (fixed)

ADAPTIVE_QP_SELECTION 0 gives build error

Reported by: kolya Owned by:
Priority: minor Milestone: HM-14.0
Component: HM Version: HM-13.0
Keywords: JCTVC-G382, HEVC encoder Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

Setting ADAPTIVE_QP_SELECTION to 0 gives build error. The patch is attached.

Btw, it seems in spite of the macro is set to 1, the method does not work by default. Is it an intended behavior of encoder?

Attachments (1)

HM-13.0.patch (757 bytes) - added by kolya 8 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

Changed 8 years ago by kolya

comment:2 Changed 8 years ago by fbossen

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r3851
The behavior of the encoder is as intended. Adaptive QP selection should be enabled using the AdaptiveQpSelection encoder configuration option.

comment:3 follow-up: Changed 8 years ago by kolya

There is no matching option in cfg-files - is it worth adding that?

comment:4 in reply to: ↑ 3 Changed 8 years ago by fbossen

Replying to kolya:

There is no matching option in cfg-files - is it worth adding that?

The sample configuration files provided in the cfg/ folder intentionally do not contain all encoder configuration parameters. There is currently no plan to change that. The software manual located in doc/software-manual.pdf should serve as a reference for all encoder configuration parameters.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Always)
  • Nikolay Shlyakhov(Reporter, Participant)