Opened 8 years ago

Closed 8 years ago

#1185 closed defect (fixed)

On the description to support high-bit depth video

Reported by: teruhiko Owned by:
Priority: major Milestone: RExt D5
Component: RExt text Version: RExt D4 (N1005) v3
Keywords: Cc: davidf, joel, teruhiko, jct-vc@…

Description

In N1005_v3, the changes to support high-bit are missing.
In N1005_v3, only the cropping changes are implemented, which is
pointless since the increased accuracy is immediately discarded
prior to the transform, reverting back to 16-bit (signed) rather
than the adopted max(16,bitDepth+7). The only part of N0188 that
was not adopted was the change in transform matrix coefficient
accuracy (the 'downshift of 7' as it was put in the notes, which
is the right shift after the first stage of inverse transform).

Section 8.6.2 and 8.6.3 should be changed as indicated in
the attached file.

Attachments (1)

JCTVC-N1005_v3_N0188_r1.zip (87.2 KB) - added by teruhiko 8 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc davidf joel teruhiko jct-vc@… added

comment:2 Changed 8 years ago by teruhiko

  • Priority changed from minor to major

Changed 8 years ago by teruhiko

comment:3 Changed 8 years ago by kiranmisra

It appears to me that the increase clipping range was intended to increase the coefficient levels throughout the decoding process. To me the changes proposed in the submitted bug-report correspond to retaining higher precision in the dequantizer and goes beyond the agreed decision. This possibly represents a mismatch between an adoption and integrated software.

comment:4 Changed 8 years ago by davidf

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in JCTVC-O1005_v1, based on meeting decision at Geneva.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • Joel(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Kiran Misra(Participant)
  • Teruhiko Suzuki(Reporter, Subscriber, Participant)