Opened 8 years ago

Closed 8 years ago

#1116 closed defect (duplicate)

Some conditions from section 8.3.1 missing in POC decoding routine

Reported by: jackh Owned by:
Priority: minor Milestone:
Component: HM Version: HM-11.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

Section 8.3.1 of the spec states:

Let prevTid0Pic be the previous picture in decoding order that has TemporalId equal to 0 and that is not a RASL picture, a RADL picture, or a sub-layer non-reference picture.

The relevant line in the reference decoder is in TComSlice.h:

Void setPOC( Int i ) { m_iPOC = i; if(getTLayer()==0) m_prevPOC=i; }

This misses out the RASL, RASL or sub-layer non-reference condition. I think this should be changed to:

Void setPOC( Int i ) { m_iPOC = i; if(getTLayer()==0 && !isRASL() && !isRADL() && !isNonReference()) m_prevPOC=i; }
Bool isRASL() const { return (getNalUnitType() == NAL_UNIT_CODED_SLICE_RASL_N) || (getNalUnitType() == NAL_UNIT_CODED_SLICE_RASL_R); }  
Bool isRADL() const { return (getNalUnitType() == NAL_UNIT_CODED_SLICE_RADL_N) || (getNalUnitType() == NAL_UNIT_CODED_SLICE_RADL_R); }  
Bool isNonReference() const { return 
                                     (getNalUnitType() == NAL_UNIT_CODED_SLICE_RADL_N) ||
                                     (getNalUnitType() == NAL_UNIT_CODED_SLICE_RASL_N) ||
                                     (getNalUnitType() == NAL_UNIT_CODED_SLICE_STSA_N) ||
                                     (getNalUnitType() == NAL_UNIT_CODED_SLICE_TRAIL_N) ||
                                     (getNalUnitType() == NAL_UNIT_CODED_SLICE_TSA_N)
                          ; }  

Change History (2)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 8 years ago by ksuehring

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #1106.
That is already fixed in HM-11.0-dev (see #1106)

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • Jack Haughton(Reporter)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)