Opened 8 years ago

Closed 8 years ago

#1089 closed defect (duplicate)

Encoder crashes when using fixed rate and fixed slice length

Reported by: jfmcarreira Owned by:
Priority: major Milestone: HM-10.1
Component: HM Version: HM-10.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

The variable LCUIdx assumes wrong values when enconding with fixed bitrate and fixed slice length.

The solution is the decrease by one the value LCUIdx when a LCU is encoded but not included in the current slice, because it exceeds the maximum size requested (fixed slice length).

This is the error:
TAppEncoderStatic_HM-10.1-dev_2013_05_09: /home/joaoc/IT/PhD/HEVC/srcHEVC-mirror/build/linux/lib/TLibEncoder/../../../../source/Lib/TLibEncoder/TEncRateCtrl.h:147: TRCParameter TEncRCSeq::getLCUPara(Int, Int): Assertion `LCUIdx < m_numberOfLCU' failed.

Change History (2)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 8 years ago by jfmcarreira

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #1090.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • Joao Carreira(Reporter, Participant)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Always)