Opened 8 years ago

Closed 8 years ago

#1088 closed defect (fixed)

Picture buffer not created when first slice segment in a picture is skipped

Reported by: peter Owned by:
Priority: major Milestone: HM-11.1
Component: HM Version: HM-10.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

If the first slice segment in a picture is RandomAccessSkipPicture or SkipPictureForBLA, xDecodeSlice() will return false prematurely. Then, if the second slice segment is a dependent slice segment, m_cGopDecoder.decompressSlice() is called without calling xGetNewPicBuffer(). (At this time, the previous picture has not done loop filtering yet.) So this slice segment will write pixels to the previous picture's buffer and corrupt the previous picture.

Change History (2)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 8 years ago by fbossen

  • Milestone changed from HM-10.1 to HM-11.1
  • Resolution set to fixed
  • Status changed from new to closed

Probably duplicate of #1125 and fixed in r3522

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Always)
  • Peter Tatman(Reporter)