Opened 8 years ago

Closed 6 years ago

#1065 closed defect (invalid)

Accessing unallocated memory when looking at colocated CUs

Reported by: pieterkapsenberg Owned by: karlsharman
Priority: minor Milestone: HM-16.5
Component: HM Version: HM-10.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

It appears that for an IDR (or I slice maybe?) picture, HM destroys or otherwise changes the m_pePredMode array, causing intra checks to fail. This shows up in TComDataCU::xGetColMVP, line 3292, where a colocated CU's intra mode is checked, and the colocated CU belongs to an IDR picture.

A crude fix is to make sure the colocated CU's slice is not intra. A patch that does this is attached

Attachments (1)

col_intra.patch (523 bytes) - added by pieterkapsenberg 8 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

Changed 8 years ago by pieterkapsenberg

comment:2 Changed 7 years ago by ksuehring

  • Milestone HM-10.1 deleted

comment:3 Changed 6 years ago by ksuehring

  • Milestone set to HM-16.5
  • Owner set to karlsharman
  • Status changed from new to assigned

comment:4 Changed 6 years ago by karlsharman

  • Resolution set to invalid
  • Status changed from assigned to closed

Unable to reproduce the problem. If others can repeat it, please re-open and give full details of configurations that highlight the issue.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • Karl Sharman(Owner, Participant)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Pieter Kapsenberg(Reporter)