Opened 8 years ago

Closed 8 years ago

#1027 closed defect (fixed)

RDOQ sign bit hiding

Reported by: karlsharman Owned by:
Priority: minor Milestone: HM-10.1
Component: HM Version: HM-9.2
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description (last modified by ksuehring)

In RDOQ, on line 1988 of TComTrQuant.cpp,

   if(piQCoef[minPos] == 32767 || piQCoef[minPos] == -32768) 

In this function (unlike in signBitHidingHDQ), piQCoef is the quantisation coefficients, rather than the quantised output array.

It should read:

   if(piDstCoeff[minPos] == 32767 || piDstCoeff[minPos] == -32768) 

Change History (5)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 8 years ago by ksuehring

  • Description modified (diff)
  • Milestone set to HM-10.1

comment:3 Changed 8 years ago by ksuehring

Ticket #1076 has been marked as a duplicate of this ticket.

comment:4 Changed 8 years ago by ksuehring

The fix has been applied in r3411

comment:5 Changed 8 years ago by ksuehring

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • Karl Sharman(Reporter)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)