Opened 9 years ago

Closed 9 years ago

#905 closed enhancement (fixed)

Confusion in scan order specification based on IntraPredMode

Reported by: peterderivaz Owned by: bbross
Priority: trivial Milestone: D9
Component: Text Version: D9 (K1003) v11
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

7.4.9.11 "Residual coding semantics" specifies the scan order in terms of a variable IntraPredMode.

However, it is not clear what is meant by IntraPredMode.

This name appears in the document as:

  1. a parameter intraPredMode for some processes
  2. an array IntraPredMode for luma prediction mode
  3. a variable IntraPredModeC for chroma prediction mode

Perhaps it should be clarified which (if any) is the correct interpretation?

Change History (3)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 9 years ago by bbross

  • Milestone set to D9

What is meant in the draft is 2. but I agree that there are several issues in the current text:

  1. Horizontal and vertical scans are also used for 4x4 chroma transform blocks, so IntraPredModeC should be considered in that case as follows:
  • If PredMode[ x0 ][ y0 ] is equal to MODE_INTRA and one or more of the following conditions are true,

– log2TrafoSize is equal to 2
– log2TrafoSize is equal to 3 and cIdx is equal to 0

predModeIntra is derived as follows.
– If cIdx is equal to 0, predModeIntra is set equal to IntraPredMode[x0][y0].
– Otherwise, predModeIntra is set equal to IntraPredModeC.

scanIdx is derived as follows.
– If predModeIntra is in the range from 6 to 14, inclusive, scanIdx is set equal to 2.
– Otherwise, if predModeIntra is in the range from 22 to 30, inclusive, scanIdx is set equal to 1.
– Otherwise, scanIdx is set equal to 0.

  • Otherwise, scanIdx is set equal to 0.
  1. The luma IntraPredMode should be addressed as an array IntraPredMode[ x0 ][ y0 ].
  1. The intra prediction mode variable names violate the convention that no variable name should be contained in another variable name so I suggest to rename:
  • IntraPredMode -> IntraPredModeY
  • intraPredMode -> predModeIntra
  • PredMode -> CuPredMode

comment:3 Changed 9 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in JCTVC-K1003_v12

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Peter de Rivaz(Reporter)
  • Woo-Jin Han(Subscriber)