Opened 9 years ago

Closed 9 years ago

#795 closed defect (fixed)

When FramesTobeEncoded > actual num frames, encoder report is different

Reported by: cohen Owned by:
Priority: minor Milestone: HM-8.2
Component: HM Version: HM-8.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

I encoded the 150-frame Traffic sequence, but mistakenly specified 300 frames as FramesToBeEncoded. The encoder ran fine, but the reported rate and maybe PSNR averages were not the same as when I specified FramesToBeEncoded to be 150. I didn't yet repeat the test so someone may want to doublecheck this on a short sequence to see if this is a bug.

Change History (7)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 9 years ago by ksuehring

Was that a random-access GOP? My first guess is that the size of the last GOP was not adapted when the last frame was encountered.

comment:3 Changed 9 years ago by cohen

I believe it was all-intra main configuration.

comment:4 Changed 9 years ago by cohen

I just did a quick test on RaceHorses (Class D), AI-Main configuration, HM8.0, specifying the correct number of frames to be encoded (300), and then an incorrect number (600). The rates/PSNRs are different:

FramesToBeEncoded: 300
4457.8544 42.4141 43.0318 43.9030 295.420
2682.7608 38.4047 39.6330 40.9007 257.850
1473.2704 34.5740 37.3667 38.6013 223.300
742.8656 31.2809 35.7765 36.8771 194.560

FramesToBeEncoded: 600
4454.5882 42.4169 43.0321 43.9036 289.790
2680.8295 38.4085 39.6332 40.9020 256.300
1472.4183 34.5786 37.3662 38.6029 218.490
742.6461 31.2855 35.7755 36.8783 190.220

comment:5 Changed 9 years ago by davidf

The cause is likely due to the file reader failing to spot it hasn't loaded the frame. Can you check the log ans see if it encodes an extra picture?

comment:6 Changed 9 years ago by cohen

Yes, that seems to be the case, and the bits/PSNRs reported for this extra picture are exactly the same as the real last picture. Here's a diff for the good and bad encoder outputs, followed by the relevant lines of the bad encoder output file:

diff good.txt bad.txt | more
9c9
< Frame index : 0 - 299 (300 frames)
---

Frame index : 0 - 599 (600 frames)

329a330

POC 300 TId: 0 ( I-SLICE, nQP 37 QP 37 ) 22560 bits [Y 32.6642 dB U 35.4876 dB V 37.2404 dB] [ET 1 ] [L0 ] [L1 ] [MD5:317cfbf5a34d40e58bb8aad14e8d4a91,03cd72d1520e7cadcab265d3c201aee4,f239ffa293da3919dce9245508b810bf]

334c335
< 300 a 742.8656 31.2809 35.7765 36.8771
---

301 a 742.6461 31.2855 35.7755 36.8783

339c340
< 300 i 742.8656 31.2809 35.7765 36.8771
---

301 i 742.6461 31.2855 35.7755 36.8783

352c353
< Bytes written to file: 947193 (757.754 kbps)
---

Bytes written to file: 950075 (757.535 kbps)

354c355
< Total Time: 194.560 sec.
---

Total Time: 190.220 sec.


Encoder output file for bad run:

POC 298 TId: 0 ( I-SLICE, nQP 37 QP 37 ) 23328 bits [Y 32.7065 dB U 35.5228 dB V 37.4423 dB] [ET 1 ] [L0 ] [L1 ] [MD5:3d512c213370e0593443d5ecf6ddc675,f29b3\
514c8f17015f015bd4a7bad5e38,532e0aded9c3f7c6d29d5669e974fd34]
POC 299 TId: 0 ( I-SLICE, nQP 37 QP 37 ) 22560 bits [Y 32.6642 dB U 35.4876 dB V 37.2404 dB] [ET 1 ] [L0 ] [L1 ] [MD5:317cfbf5a34d40e58bb8aad14e8d4a91,03cd7\
2d1520e7cadcab265d3c201aee4,f239ffa293da3919dce9245508b810bf]
POC 300 TId: 0 ( I-SLICE, nQP 37 QP 37 ) 22560 bits [Y 32.6642 dB U 35.4876 dB V 37.2404 dB] [ET 1 ] [L0 ] [L1 ] [MD5:317cfbf5a34d40e58bb8aad14e8d4a91,03cd7\
2d1520e7cadcab265d3c201aee4,f239ffa293da3919dce9245508b810bf]

comment:7 Changed 9 years ago by davidf

  • Milestone set to HM-8.2
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r2918.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber, Participant)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Robert Cohen(Reporter, Participant)