Opened 12 years ago

Closed 12 years ago

#766 closed defect (fixed)

clarification of NumPCMBlock

Reported by: sasai Owned by: bbross
Priority: minor Milestone:
Component: Text Version: D8 (K0030) v3
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

"NumPCMBlock=0" in coding_tree_unit() is not necessary
since NumPCMBlock is decremented in pcm_sample().

Change History (5)

comment:1 Changed 12 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 12 years ago by bbross

NumPCMBlock=0 is needed in coding_tree_unit() syntax in order to invoke CU syntax for the first time:

if( NumPCMBlock = = 0 )

coding_unit( x0, y0, log2CbSize )

where NumPCMBlock may get set to

NumPCMBlock = num_subsequent_pcm + 1

Then, when NumPCMBlock is greater than zero, the remaining NumPCMBlock-1 CUs are decoded using pcm_sample() syntax instead of coding_unit() syntax, where NumPCMBlock is decremented, until NumPCMBlock is equal to 0:

if( NumPCMBlock = = 0 )

coding_unit( x0, y0, log2CbSize )

else

pcm_sample( x0, y0, log2CbSize )

But I would propose to rename NumPCMBlock to NumPcmUnits since it specifies the number of PCM units including one luma and two chroma blocks.

comment:3 Changed 12 years ago by sasai

Yes, NumPCMBlock has to be set to 0 for first time.
We thought that "NumPCMBlock=0" is not necessary in "every" coding_tree_unit().
It seems to be enough only once at a slice or sequence.
Anyway, it would be trivial.

comment:4 Changed 12 years ago by kchono

As Benjamin said, NumPCMBlock=0 is needed in coding_tree_unit() syntax. Although Sasai-san's comment ( NumPCMBlock=0 is needed once per a slice ) is true, I think that keeping "NumPCMBlock=0" in coding_tree_unit() syntax is reasolable.

Regarding the variable name, I think that "NumPcmUnit" sounds better.

Thank you very much.

comment:5 Changed 12 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

OK, I see but I agree with Chono-san that conditioning "NumPCMBlock=0" on the first CTU of a slice would not really simplify syntax.

Anyway, NumPCMBlock will be renamed to NumPcmUnits in JCTVC-K0030_v4.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Keiichi Chono(Participant)
  • sasai(Reporter, Participant)
  • Woo-Jin Han(Subscriber)