Opened 9 years ago

Closed 8 years ago

#740 closed enhancement (duplicate)

8.6.1 : qPy_prev derivation when entropy_coding_sync_enalbed_flag = 1 is incorrect

Reported by: Jing-Jing Chung Owned by: bbross
Priority: minor Milestone: D10
Component: Text Version: D10 (L1003) v2
Keywords: quantization Cc: bbross, wjhan, jct-vc@…

Description

In chapter 8.6.1 : Derivation process for quantization parameters, the following condition to derive of qPY_prev is incorrect :

"The current quantization group is the first quantization group in a coding tree block row and entropy_coding_sync_enabled_flag is equal to 1." (taking into account ticket #721)

According to entropy_coding_sync_enabled_flag definition :

"entropy_coding_sync_enabled_flag equal to 1 specifies that a specific synchronization process for context variables is invoked before decoding the first coding tree block of a row of coding tree blocks in each tile..."

the condition should be :

The current quantization group is the first quantization group in a coding tree block row of a tile and entropy_coding_sync_enabled_flag is equal to 1.

Change History (10)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 9 years ago by bbross

  • Type changed from defect to enhancement

This is related to #659 and given that we have only one profile with the following constraint, the current draft text is correct.
"– Picture parameter sets shall have tiles_enabled_flag && entropy_coding_sync_enabled_flag equal to 0."
In both cases we should first add a note saying that this does not work for the case where tiles_enabled_flag=1 and entropy_coding_sync_enabled_flag=1.

Furthermore, this is related to the work of AhG4 on high-level parallelism.

comment:3 Changed 8 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 8 years ago by bbross

  • Resolution fixed deleted
  • Status changed from closed to new

comment:5 Changed 8 years ago by bbross

  • Version changed from D8 (J1003) d7 to D9 (K1003) v10

comment:6 Changed 8 years ago by bbross

  • Version changed from D9 (K1003) v10 to D9 (K1003) v11

comment:7 Changed 8 years ago by bbross

  • Version changed from D9 (K1003) v11 to D10 (L1003) v1

comment:8 Changed 8 years ago by bbross

  • Milestone set to D10

comment:9 Changed 8 years ago by bbross

  • Version changed from D10 (L1003) v1 to D10 (L1003) v2

comment:10 Changed 8 years ago by bbross

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #659.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Woo-Jin Han(Subscriber)