Opened 9 years ago

Closed 9 years ago

#695 closed enhancement (fixed)

prefix of firstGreater1ScanPos

Reported by: PhuongNguyen Owned by: bbross
Priority: minor Milestone: D8
Component: Text Version: D8 (J1003) d7
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

Hello,

actually, variable firstGreater1ScanPos is derived as followed :

firstGreater1ScanPos = -1
...
if (coeff_abs_level_greater1_flag[n] && firstGreater1ScanPos == -1)

firstGreater1ScanPos = n

This means that firstGreater1ScanPos is the first coefficient read from the bitstream having absolute value greater than 1 when we scan from high frequency to low frequency.

The prefix first is used rather for the LAST element in a scan from high frequency to low frequency. This is the case for firstSigScanPos.

I am wondering if we should call it lastGreater1ScanPos instead of
firstGreater1ScanPos in order to respect the prefix convention in the spec.

Also, could you please point me to a discussion or study on the use of firstGreater1ScanPos?

Best regards,
Phuong Nguyen.

Change History (2)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 9 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

I agree that there is an inconsistency in what last and first means but we need to consider also last_significant_coeff_* in that context. In summary we have:

  • last_significant_coeff_x/y_prefix/suffix (first in scan order)
  • LastSignificantCoeffX/Y (first in scan order)
  • lastScanPos (first in scan order)
  • lastSubBlock (first in scan order)
  • firstSigScanPos (last in scan order)
  • lastSigScanPos (first in scan order)
  • firstGreater1ScanPos (first in scan order)

Given this, I agree that firstGreater1ScanPos is the only variable name that deviates from this and thus should be changed to lastGreater1ScanPos.

This will be fixed in JCTVC-K0030_v3 (to be released).

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Woo-Jin Han(Subscriber)