Opened 10 years ago

Closed 10 years ago

#669 closed defect (duplicate)

HM-8.0: Enabling dependent slices causes encoder/decoder mismatch.

Reported by: pieterkapsenberg Owned by:
Priority: minor Milestone: HM-8.1
Component: HM Version: HM-8.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

(No entry for HM-8.0 in the tracker)

Encoding a sequence with the following added to the cfg:

DependentSliceMode : 2
DependentSliceArgument : 15000
CabacIndependentFlag : 0

causes digest mismatches when running the decoder.

Attachments (2)

depslices.cfg (7.8 KB) - added by pieterkapsenberg 10 years ago.
RaceHorses_lowdelay_dep_slices.bin (25.2 KB) - added by pieterkapsenberg 10 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 10 years ago by ksuehring

  • Version changed from HM-7.1 to HM-8.0

comment:3 Changed 10 years ago by pieterkapsenberg

In particular, the RaceHorses stream looks too "green", the later slices have an odd green tint, suggesting maybe a qP issue propagating between the dependent slices.

comment:4 Changed 10 years ago by pieterkapsenberg

Also, the slice header syntax regarding the dependent_slice flag does not match the Text.

comment:5 Changed 10 years ago by ksuehring

High level syntax changes are usually applied in the x.1 versions, so we are probably on track with that. Actually I'm not sure if I have already seen anybody volunteering for implementing that ad-hoc change, but we can take care of it.

Regarding the mismatch we had problems reproducing it. Can you please share the complete configuration you used?

Changed 10 years ago by pieterkapsenberg

Changed 10 years ago by pieterkapsenberg

comment:6 Changed 10 years ago by pieterkapsenberg

stream and cfg attached, ran with this command line:

./bin/TAppEncoderStatic --SEIpictureDigest -c depslices.cfg -fr 30 -i ../yuv/RaceHorses_832x480_30.yuv -f 1 -wdt 832 -hgt 480 -b RaceHorses_lowdelay_dep_slices.bin

comment:7 Changed 10 years ago by adarsh

There is another minor inconsistency with the implementation of dependent slices. The dependent slice is signalled by dependent_slice_flag, and dependent_slices_enabled_flag only signals whether dependent_slice_flag is present in the slice header or not. In most places in the the software (HM8.0), the variable for dependent_slices_enabled_flag, which is m_bDependentSlicesEnabledFlag, is used to check if the slice is a dependent slice.

comment:8 Changed 10 years ago by ksuehring

It seem the issue is not directly related to dependent slices. The configuration file uses:

DeltaQpRD: 1

which also causes mismatches for "regular" slices. I have tested using SliceMode:1 and 2, the mismatch happens for both.

comment:9 Changed 10 years ago by ksuehring

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #671.
I'll mark this a as duplicate for 671 which has the description of the actual cause of the mismatch.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Adarsh Krishnan Ramasubramonian(Participant)
  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Pieter Kapsenberg(Reporter, Participant)