Opened 11 years ago

Closed 7 years ago

Last modified 7 years ago

#59 closed enhancement (fixed)

Memory issue - unnecessarily long variable type

Reported by: wjhan Owned by:
Priority: minor Milestone: HM-16.0
Component: HM Version: HM-16.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

Comments from Tourapis, Alexis. Thanks!

Currently motion vector and reference indices use Int-type variable. There are other cases using unnecessarily long variable type. Check them and replace them by suitable types. It can reduce memory considerably.

Change History (7)

comment:1 Changed 10 years ago by fbossen

  • Version set to HM-3.4

Do quantized transform coefficients require 32-bit storage?

typedef Int TCoeff;

comment:2 Changed 9 years ago by davidf

  • Component set to HM

Updating component after adding WD (Text) tickets

comment:3 Changed 9 years ago by davidf

  • Cc fbossen ksuehring davidf added

comment:4 Changed 9 years ago by davidf

  • Cc jct-vc@… added

comment:5 Changed 7 years ago by fbossen

  • Type changed from defect to enhancement

comment:6 Changed 7 years ago by ksuehring

  • Milestone set to HM-16.0
  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from HM-3.4 to HM-16.0

Several changes have been applied over time to reduce memory usage. Thus I'm closing this general bug.

If anything is still open, please open new issues with concrete suggestions.

comment:7 Changed 7 years ago by ksuehring

Ticket #57 has been marked as a duplicate of this ticket.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber, Participant)
  • Frank Bossen(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Woo-Jin Han(Reporter)