Opened 9 years ago

Closed 9 years ago

#413 closed defect (fixed)

Missing condition for Eq. (7-24) in calculation of Log2MinCUDQPSize

Reported by: Haoping Yu Owned by: bbross
Priority: major Milestone: D7
Component: Text Version: D6 (H1003) dI/dJ/dK
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

In the semantics of max_cu_qp_delta_depth, the variable Log2MinCUDQPSize is calculated as in Eq. (7-24) only when max_cu_qp_delta_depth is greater than 0. However, this condition is missing in the current CD text.
Suggested fix: add this condition as below.
When max_cu_qp_delta_depth>0, the variable Log2MinCUDQPSize specifying the minimum size of coding units that convey cu_qp_delta, is derived as follows.
Log2MinCUDQPSize = Log2MaxCUSize − (max_cu_qp_delta_depth − 1) (7-24)

In addition, a typo in “Its a requirement of bitstream conformance …” should be replaced by “It is a requirement of bitstream conformance …”.

Change History (4)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 9 years ago by bbross

  • Version set to D6 (H1003) dI/dJ/dK

comment:3 Changed 9 years ago by bbross

  • Milestone set to D7

I don't see a reason why Log2MinCUDQPSize should be conditioned on max_cu_qp_delta_depth>0. This does not changes the normative behavior.

In HLS text of d7, max_cu_qp_delta_depth is renamed to diff_cu_qp_delta_depth and “Its a requirement of bitstream conformance …” is removed. Furthermore, all occurrences of log2MinCUDQPSize should be renamed to Log2MinCUDQPSize.

comment:4 Changed 9 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in JCTVC-I1003 d4.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • Haoping Yu(Reporter)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Woo-Jin Han(Subscriber)