Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#266 closed defect (wontfix)

ZERO_MVD_EST fix

Reported by: Tammy Owned by:
Priority: minor Milestone: HM-16.2
Component: HM Version: HM-5.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

ZERO_MVD_EST(default: 0) bug is fixed. The related change is marked by ZERO_MVD_EST_FIX.

Attachments (1)

ZeroMvdEst_Fix.patch (9.0 KB) - added by Tammy 9 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf added

Changed 9 years ago by Tammy

comment:2 Changed 9 years ago by ksuehring

Can you please edit the description to say what kind of bug this is supposed to fix. I think saying some bug is fixed is not a valid problem description.

comment:3 Changed 9 years ago by Tammy

ZERO_MVD_EST(default: 0) bug is fixed and the related change is marked by ZERO_MVD_EST_FIX.
The bug was caused by the change of setAllMvField function's parameters and the addition of DistParam's new members (which were inserted by WEIGHT_PRED) without proper setting. Since the default value of this macro is zero, no performance change is observed by this bugfix in the default test configuration.

comment:4 Changed 9 years ago by davidf

  • Cc jct-vc@… added

comment:5 Changed 7 years ago by fbossen

Compilation with ZERO_MVD_EST set to 1 fails in r3777

comment:6 Changed 7 years ago by ksuehring

  • Resolution set to wontfix
  • Status changed from new to closed

The code related to ZERO_MVD_EST has been removed in r4162

comment:7 Changed 7 years ago by ksuehring

  • Milestone set to HM-16.2
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber, Participant)
  • Frank Bossen(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Tammy(Reporter, Participant)