Opened 10 years ago

Closed 9 years ago

#188 closed defect (wontfix)

HM-3.2 encoder/decoder mismatch (please see attached cfg file)

Reported by: madhukar Owned by:
Priority: major Milestone:
Component: HM Version: HM-3.2
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

HM3.2 has encoder-decoder mismatch with the attached config file, cfg2 (DQP depth 1 and fine granularity slice with depth 3).

Attachments (3)

cfg2.txt (5.5 KB) - added by madhukar 10 years ago.
cfg2-2.txt (5.5 KB) - added by madhukar 10 years ago.
Fix188.HM40.patch (2.6 KB) - added by hao 10 years ago.

Download all attachments as: .zip

Change History (14)

Changed 10 years ago by madhukar

comment:1 Changed 10 years ago by fbossen

Could not replicate issue with HM 3.3.

Changed 10 years ago by madhukar

comment:2 Changed 10 years ago by madhukar

Please see new attached cfg file (cfg2-2.txt).

comment:3 Changed 10 years ago by peterchuang

I use HM3.4-dev rev.1322 with the cfg2-2.txt config file, but disable the DQP as follows:

MaxDeltaQP : 0
MaxCuDQPDepth : 0

The decoder will crash.

comment:4 Changed 10 years ago by peterchuang

The HM4.0rc1 still has the same problem described above (enabling fine grain slice while disabling sub-LCU DQP).

comment:5 Changed 10 years ago by hao

I tried running HM-4.0 with cfg2-2.txt on Windows 7 Professional PC and got following results.

  • With FGS and without DQP, neither crash nor mismatch has occured.
  • With both FGS and DQP, mismatch has occured.

Changed 10 years ago by hao

comment:6 Changed 10 years ago by hao

I believe that I have succeeded in fixing this issue.
Please see the attached patch file.

The problem is as follows.

  • TEncCu::xCompressCU() does not know whether the LCU is split into more than one FGS or not.
  • FGS partition is decided after TEncCu::xCompressCU().
  • If a CU before split has any coefficients but the modified CU which is cut down by FGS partitioning does not have, QP must be reset to the predicted QP.

I don't have complete understanding of FGS implementation, so it would be appreciated if others having deeper understanding of FGS implementation could check whether this fix is correct or not.

comment:7 Changed 10 years ago by hao

Sorry, the patched HM-4.0 still has the same problem, though in some cases the patch fixes encoder-decoder mismatch.

comment:8 Changed 10 years ago by davidf

  • Component set to HM

Updating component after adding WD (Text) tickets

comment:9 Changed 10 years ago by davidf

  • Cc fbossen ksuehring davidf added

comment:10 Changed 10 years ago by davidf

  • Cc jct-vc@… added

comment:11 Changed 9 years ago by ksuehring

  • Resolution set to wontfix
  • Status changed from new to closed

Fine granularity slices have been removed from the spec.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber, Participant)
  • Frank Bossen(Subscriber, Participant)
  • Hirofumi Aoki(Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Madhukar Budagavi(Reporter, Participant)
  • Peter Chuang(Participant)