Opened 21 months ago

Closed 6 weeks ago

#1499 closed defect (fixed)

Equation 8-47 in v5 spec was inadvertently changed from v4 spec

Reported by: RyanLei Owned by:
Priority: minor Milestone: v5
Component: Text Version: v5 (02/2018)
Keywords: Cc: jill.boyce@…, bbross, wjhan, jct-vc@…

Description

In the v5 spec, equation 8-47, for dcVal calculation, neighboring predicted pixels are summed up and right shifted by (k-1) bits. It seems to be a mistake caused by formatting. Correct operation should be right shift by (k+1) bits. The same equation in v4 spec is correct. Reference code implementation is correct.

Change History (1)

comment:1 Changed 6 weeks ago by crosewarne

  • Resolution set to fixed
  • Status changed from new to closed

Confirmed fixed in H.265 (11/19).

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Subscriber)
  • jct-vc@…(Subscriber)
  • jill.boyce@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Woo-Jin Han(Subscriber)
  • Zhijun (Ryan) Lei(Reporter)