Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1330 closed defect (fixed)

Repeated reference picture sets cause dangling pointers

Reported by: jackh Owned by:
Priority: minor Milestone: HM-16.3
Component: HM Version: HM-16.1
Keywords: Cc: ksuehring, davidf, karlsharman, jct-vc@…

Description

This is a repeat of #1099, but as that ticket is so old I thought it would be best to repost with updated patches.

It is legal to repeat the active SPS and VPS during a CVS, provided that its content doesn't change. However, the reference code stores pointers to SPS and VPS objects on each picture, and deletes the active set if such repeating occurs, leaving dangling pointers on the pictures. Our patch stores all the pointers in a list and deletes them when the reference decoder shuts down, ensuring that any previous stored pointers remain valid.

Patches are attached for HM-16.1 and HM-15.0+RExt-8.1.

Attachments (2)

repeated-PS-HM-15.0-RExt-8.1.patch (2.5 KB) - added by jackh 7 years ago.
repeated-PS-HM-16.1.patch (2.5 KB) - added by jackh 7 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by DefaultCC Plugin

  • Cc ksuehring davidf karlsharman jct-vc@… added

Changed 7 years ago by jackh

Changed 7 years ago by jackh

comment:2 Changed 7 years ago by ksuehring

Ticket #1099 has been marked as a duplicate of this ticket.

comment:3 Changed 7 years ago by ksuehring

  • Milestone HM-16.2 deleted

comment:4 Changed 7 years ago by karlsharman

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r4219 by placing a constant instance of the SPS and PPS within
TComPicSym. The SPS/PPS pointers within a slice point to the instance
within the TComPicSym. The decoder will abort if the active PPS/SPS
changes whilst decoding a picture.

comment:5 Changed 7 years ago by karlsharman

  • Milestone set to HM-16.3

Batch modify of recently closed tickets to set milestone to HM-16.3.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Jack Haughton(Reporter)
  • jct-vc@…(Subscriber)
  • Karl Sharman(Subscriber, Participant)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)