Opened 3 years ago

Last modified 5 weeks ago

#1315 new defect

Inconsistent variable naming: CpbCnt

Reported by: ksuehring Owned by:
Priority: minor Milestone: v5
Component: Text Version: v4 (12/2016)
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

The variable name CpbCnt loses the "_minus1" when being initialized which might be confusing:

The variable CpbCnt is set equal to cpb_cnt_minus1[ subLayerId ].

It would be more consistent with our naming rules to initialize it as follows

The variable CpbCnt is set equal to cpb_cnt_minus1[ subLayerId ] + 1.

And replace the "<=" in the syntax loops with "<".

(This applies also for version 2 integrated text JCTVC-R1013_v4)

Change History (2)

comment:1 Changed 3 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 5 weeks ago by bbross

  • Milestone set to v5
  • Version set to v4 (12/2016)

Agreed by the authors of the AHG2 report JCTVC-AD0002. CpbCnt is also used several times to specify an inclusive range (in addition to the <= to < suggested change).
Fixes:

  • The variable CpbCnt is set equal to cpb_cnt_minus1[ subLayerId ] + 1 instead of cpb_cnt_minus1[ subLayerId ]
  • replace the "<=" in the syntax loops with "<", and adjust other places containing CpbCnt accrodingly.
  • In F.14.3.2.2, change the two instances of "in the range of 0 to CpbCnt." to include the word "inclusive" and adapt the range accordingly as well.
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Subscriber, Participant)
  • David Flynn(Always)
  • jct-vc@…(Subscriber)
  • Karl Sharman(Always)
  • Karsten Suehring(Reporter, Always)
  • Woo-Jin Han(Subscriber)