Opened 11 years ago

Closed 11 years ago

#13 closed defect (fixed)

Memory leakage in TMuC software?

Reported by: arild.fuldseth@… Owned by:
Priority: major Milestone:
Component: HM Version:
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

I am observing that when encoding the longer 1080p sequences (Cactus, BasketballDrill, BQTerrace) on Windows, the encoder crashes at exactly the same frame number (=496), independent of QP value and sequence. This seems to coincide with the commit charge reaching about 2GB. Is this to be expected? (2GB sounds like a huge number given the frame size.) The issue is present in revision 17, but not in the initial stripped A124 software (revision 3 I believe).

The decoder seems to have similar problems, even for some class C sequences. The commit charge quickly increases to 2 GB after encoding a few frames.

Details:

  • I am using the Beta script with unmodified configuration files and fast encoder settings (cft-fast).
  • The problem is present on Windows XP/32-bit OS and on Windows 7/64 bit OS when compiling with “32-bit settings”.
  • Compiling with “64 bit settings” and/or enabling large addresses when linking and running on 64-bit Windows OS seems to fix the problem for both the encoder and decoder (although the decoder slows down significantly when exceeding 4 GB working its way up to 18 GB commit charge  ).

Change History (4)

comment:1 Changed 11 years ago by ksuehring

  • Resolution set to fixed
  • Status changed from new to closed

The fix has been submitted to the 0.3-bugfix branch.

comment:2 Changed 10 years ago by davidf

  • Component set to HM

Updating component after adding WD (Text) tickets

comment:3 Changed 10 years ago by davidf

  • Cc fbossen ksuehring davidf added

comment:4 Changed 10 years ago by davidf

  • Cc jct-vc@… added
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • arild.fuldseth@…(Reporter)
  • David Flynn(Subscriber, Participant)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)