Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1223 closed defect (invalid)

No CABAC contexts reset in WPP when slice segments starts on a new row

Reported by: gregory Owned by:
Priority: major Milestone:
Component: HM Version: HM-12.1
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

In WPP mode for CTB at the start of a row CABAC contexts should be loaded from top-right CTB or reset in case top-right CTB is not available (e.g. in a different slice). In case of dependent slice segments reset is done only when top-right CTB is outside of the frame.

I attached a 1-frame stream which reproduces this problem and a patch which fixes it for decoder.

Looking at the source code I think the same problem exists in encoder.

Attachments (2)

DSLICE-WPP.hevc (75.9 KB) - added by gregory 8 years ago.
Reproducing stream, CTB number where reset should happen is 9.
dslice-wpp.patch (900 bytes) - added by gregory 8 years ago.
Patch for decoder

Download all attachments as: .zip

Change History (4)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

Changed 8 years ago by gregory

Reproducing stream, CTB number where reset should happen is 9.

Changed 8 years ago by gregory

Patch for decoder

comment:2 Changed 8 years ago by ksuehring

  • Milestone HM-13.0 deleted
  • Resolution set to invalid
  • Status changed from new to closed

The provided bitstream is not conforming because it does not follow the constraint of entropy_coding_sync_enabled_flag:

When entropy_coding_sync_enabled_flag is equal to 1 and the first
coding tree block in a slice is not the first coding tree block of a
row of coding tree blocks in a tile, it is a requirement of bitstream
conformance that the last coding tree block in the slice shall belong
to the same row of coding tree blocks as the first coding tree block
in the slice.

Last edited 8 years ago by ksuehring (previous) (diff)
Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • Gregory Shimansky(Reporter)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)