Opened 8 years ago

Closed 7 years ago

#1190 closed defect (fixed)

Field decoding is not working fine

Reported by: satish Owned by:
Priority: critical Milestone: HM-12.1
Component: HM Version: HM-11.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

Hi,
In HM 11.0 version Field decoding output is visually not good.
I have attached the encoder config file from which the stream generated.
when i decode the stream field_seq_flag is always zero for pic_struct 1 or 2 which is conflict with the spec "Table D.2 – Interpretation of pic_struct".
In the encoder code field_seq_flag is always set to false.

Attachments (1)

encoder_randomaccess_field.cfg (10.8 KB) - added by satish 8 years ago.
Encoder config file

Download all attachments as: .zip

Change History (5)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

Changed 8 years ago by satish

Encoder config file

comment:2 Changed 8 years ago by ksuehring

Please use HM-12.0-dev for interlace coding. Interlace GOP support has been added after HM-11.0 and there are also some fixes in the current development branch. There also exists an example configuration in cfg/misc

comment:3 Changed 8 years ago by satish

I took HM 12.0-dev code and encoded with cfg/misc configuration file,even though the decoded output is visually not good.
I generated encoded stream for 5 frames.If i give 20 frames the following assertion encountered,

" Assertion failed: rpcPic->getPOC() < this->getPOC(), file d:\hevc\hm-12.0-dev\source\lib\tlibcommon\tcomslice.cpp , line 868 "

Do you i need to add any patches to fix this as it seems there are few patches in the bug tracker ?

comment:4 Changed 7 years ago by fbossen

  • Resolution set to fixed
  • Status changed from new to closed

Could not reproduce issue with r3790

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • satish(Reporter, Participant)