Opened 8 years ago

Closed 7 years ago

#1132 closed defect (fixed)

incorrect decoded picture buffer reordering with IDR

Reported by: stefano913 Owned by:
Priority: minor Milestone:
Component: HM Version: HM-11.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

The HM11.0 decoder seems to not correctly reorder the decoded pictures buffer (DPB) when more than an IDR picture is present in a sequence.

With the attached configuration file (which produces the sequence IDR-P-IDR), the encoder DPB correctly reorder the pictures as 0-1-2. By decoding the bitstream generated by the encoder, the decoder reconstructed sequence is not matching the encoder due to the wrong reordering 2-0-1.

The HM11.0rc1 was used for both the encoder and decoder.

Attachments (1)

encoder_inter_ipp.cfg (7.1 KB) - added by stefano913 8 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

Changed 8 years ago by stefano913

comment:2 Changed 7 years ago by fbossen

  • Resolution set to fixed
  • Status changed from new to closed

Was not able to reproduce the issue with r3782

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Always)
  • stefano913(Reporter)