Opened 5 years ago

Closed 5 months ago

#1114 closed enhancement (duplicate)

Question about log2_max_mv_length_horizontal

Reported by: peterderivaz Owned by:
Priority: minor Milestone: v5
Component: Text Version: v4 (12/2016)
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

In "8.5.3.2 Derivation process for motion vector components and reference indices" there is a note that the resulting values of mvLX[0] and mvLX[1] will always be in the range -2^15 to 2^15-1.

However, in "E.2.1 VUI parameters semantics" the semantics for log2_max_mv_length_horizontal say that a value of 16 can be sent, meaning that no value of a horizontal motion vector component is outside the range -2^16 to 2^16-1, although the default value is 15 if no bitstream restriction parameters are present.

This 16 seems odd because:

  1. it appears impossible to code a motion vector that would require the value of 16
  2. the vertical range is limited to 15
  3. it is using a "bitstream restriction" to extend the range of motion vectors (all other fields in this structure restrict the allowed range)

Question: Should this 16 be a 15, or have I misunderstood something?

Change History (2)

comment:1 Changed 5 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 5 months ago by bbross

  • Milestone set to v5
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from D10 (L1003) v33 to v4 (12/2016)

Closed as duplicate of #1384.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • Karl Sharman(Always)
  • Karsten Suehring(Always)
  • Peter de Rivaz(Reporter)
  • Woo-Jin Han(Subscriber)