Opened 7 years ago

Closed 7 years ago

#1098 closed defect (invalid)

wrong POC referencing while building combined bi-predictive merging candidates

Reported by: tee.jung Owned by:
Priority: critical Milestone: HM-10.1
Component: Text Version: D10 (L1003) v33
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

I found some weird condition from '8.5.3.2.3 Derivation process for combined bi-predictive merging candidates'.

A merging candidate list mergeCandList includes temporal merge candidate, but POC comparison between L0combCandk and L1combCandk does not consider the case that L0combCandk or L1combCandk comes from temporal merge candidate, as in below:

  • ( DiffPicOrderCnt( RefPicList0[ refIdxL0l0Cand ], RefPicList1[ refIdxL1l1Cand ] ) != 0 ) | | ( mvL0l0Cand != mvL1l1Cand )

RefPicList0/1 are defined as L0/L1 list of a slice, so if l0Cand or l1Cand is temporal merging candidate then refPicListL0/1 of co-locate picture should be referred instead of RefPicList0/1.

And in case that, num_ref_idx_l0_active_minus1 of current slice is lesser than num_ref_idx_l0_active_minus1 of co-located picture, RefPicList0[ refIdxL0l0Cand ] can cause referencing on undefined value.

Is this intended behavior?

Change History (2)

comment:1 Changed 7 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 7 years ago by tee.jung

  • Resolution set to invalid
  • Status changed from new to closed

Sorry for confusing.

When deriving temporal merging candidate, refIdxLXCol are set equal to 0, which means reference picture of current PU is first picture of RefPicListX, so refering RefPicListX to obtain POC of temporal merge candidate while combined bi-predictive merging candidate seems no problem.

Regards,
Tee

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Tee Jung(Reporter, Participant)
  • Woo-Jin Han(Subscriber)