Opened 8 years ago

Closed 8 years ago

#1071 closed defect (fixed)

Nonconforming RPS in CRA pictures

Reported by: fbossen Owned by:
Priority: major Milestone: HM-10.1
Component: HM Version: HM-10.0
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

It appears that the RPS associated with CRA pictures in the "random access" encoder configurations produces a value of NumPocTotalCurr that is nonzero.
This doesn't conform to the following restriction expressed in section 8.3.2 of the specification:
"If the current picture is a BLA or CRA picture, the value of NumPocTotalCurr shall be equal to 0."

The RPS associated with CRA pictures should be modified in the HM encoder such that all "used" flags are equal to 0.

Change History (8)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 8 years ago by fbossen

A quick fix was submitted in r3408.

comment:3 Changed 8 years ago by peterderivaz

Would it be worth adding a check in the decoder software for this? I think some of the conformance bitstreams do not conform to this restriction at the moment.

For example, the initial frame of RAP_A_docomo_3 is a CRA picture with 4 used reference frames.
Also the frame with POC 32 of SAO_B_MediaTek_2 is a CRA picture with 4 reference frames all marked as being used.

comment:4 Changed 8 years ago by ksuehring

The decoder check has already been added in r3410

comment:5 Changed 8 years ago by ksuehring

  • Priority changed from blocker to major

Reducing priority since a quick fix has already been applied. But the fix should still be improved.

comment:6 follow-up: Changed 8 years ago by HEVCJiang

this fix maybe lead a new bug.

i test the newest HM10.0 and HM10.1 with BBC's ra_main file like BasketballDrill_832x480_50_qp22.bin. it will crash.

if #define FIX1071 0 in typedef.h, no crash

test file from:
ftp://ftp.kw.bbc.co.uk/hevc/hm-10.0-anchors/bitstreams/ra_main/

comment:7 in reply to: ↑ 6 Changed 8 years ago by fbossen

The HM 10.0 anchors that you refer to have conformance issues. The assertion failure in the decoder is the intended behavior.
BTW, there is no "newest HM 10.0", only one version under tags/HM-10.0

Replying to HEVCJiang:

this fix maybe lead a new bug.

i test the newest HM10.0 and HM10.1 with BBC's ra_main file like BasketballDrill_832x480_50_qp22.bin. it will crash.

if #define FIX1071 0 in typedef.h, no crash

test file from:
ftp://ftp.kw.bbc.co.uk/hevc/hm-10.0-anchors/bitstreams/ra_main/

comment:8 Changed 8 years ago by ksuehring

  • Resolution set to fixed
  • Status changed from new to closed

an improved fix has been committed in r3496

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Reporter, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • Jiang(Participant)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Participant, Always)
  • Peter de Rivaz(Participant)