Opened 9 years ago

Closed 9 years ago

#1037 closed defect (fixed)

Additional ScanOrder required when Log2MinTrafoSize==3

Reported by: peterderivaz Owned by: bbross
Priority: minor Milestone: D10
Component: Text Version: D10 (L1003) v28
Keywords: Cc: bbross, wjhan, jct-vc@…

Description

Applies to JCTVC-L1003_v28 and earlier.

When Log2MinTrafoSize==3, this means that luma will use 8x8 transform, but chroma can still use 4x4 transform.

This results in a slight problem when a transform_unit with Log2TrafoSize==3 calls residual_coding( x0, y0, log2TrafoSize − 1, 1 ).

The problem is that residual_coding accesses the array ScanOrder[ log2TrafoSize − 2 ][ scanIdx ][ lastSubBlock ][ 0 ], where the first index is 0.

However, this array is defined in the semantics for "log2_diff_max_min_transform_block_size" only for blocksizes from Min( 2, Log2MinTrafoSize − 2 ) to 3.

Perhaps the fix is to simply define the array for blocksizes from 0 to 3? Or maybe Max(0,Min(2,Log2MinTrafoSize-3))?

Change History (4)

comment:1 Changed 9 years ago by DefaultCC Plugin

  • Cc bbross wjhan jct-vc@… added

comment:2 Changed 9 years ago by bbross

  • Milestone changed from HM-10.1 to D10
  • Version changed from D10 (L1003) v23 to D10 (L1003) v28

comment:3 Changed 9 years ago by bbross

Since this is a specification and not an optimized implementation I suggest that we go by the simplest solution which is your first suggestion to always define the array for indices from 0 to 3.

comment:4 Changed 9 years ago by bbross

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in v31.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Benjamin Bross(Owner, Subscriber, Participant)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Always)
  • Peter de Rivaz(Reporter)
  • Woo-Jin Han(Subscriber)