Opened 8 years ago

Closed 8 years ago

#1024 closed defect (invalid)

QP prediction may be not aligned with the spec when diff_cu_qp_delta_depth > 0

Reported by: adolgoborodov Owned by:
Priority: minor Milestone:
Component: HM Version: HM-9.2
Keywords: Cc: fbossen, ksuehring, davidf, jct-vc@…

Description

In HM-10.0 when there are multiple CU in quantization group and only the last CU has nonzero coefficients, all the CUs of the quantization group are initialized with sliceQp and only the last CU gets QP decoded as specified in the spec. If this is the case for the 1st quantization group in the CTU, then for prediction of the QP in the second quantization group the value of sliceQp will be used as left predictor qP_Y_A and not the QP value decoded for the previous quantization group.

The JCTVC_L1003_v23 clause 8.6.1 says "The luma size of a quantization group, Log2MinCuQpDeltaSize, determines the luma size of the smallest area inside a coding tree block that shares the same qPY_PRED" that means, to my understanding, that the QP value decoded with the last CU of the quantization group in the example above should be applied to all the CUs of the quantization group for QP prediction purposes.

Change History (2)

comment:1 Changed 8 years ago by DefaultCC Plugin

  • Cc fbossen ksuehring davidf jct-vc@… added

comment:2 Changed 8 years ago by adolgoborodov

  • Resolution set to invalid
  • Status changed from new to closed

This is an intended behavior and is aligned with the spec, as confirmed by B. Bross and other experts.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • David Flynn(Subscriber)
  • Frank Bossen(Subscriber)
  • jct-vc@…(Subscriber)
  • karl.sharman@…(Always)
  • Karsten Suehring(Subscriber, Always)