Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#106 closed defect (fixed)

Inter-view bi-prediction mismatch with identical motion

Reported by: dechang Owned by: tech
Priority: minor Component: HTM software
Version: HTM-14.0 Keywords:
Cc: tech, jct-3v@…

Description

  • Inter-view bi-prediction mismatch with identicalMotion Mismatch case conditions: V2 are bi-predicted from V0 and V1. (V0->V2<-V1) No Weighted Bi prediction is used. Forward MV0 is equal to backward MV1. RefPOCL0 is equal to RefPOCL1

Influence:

2 views beyond (such as 3 views)
If we only target 2 views, we can ignore this potential bug.

Attachments (1)

ticket106.patch (1.7 KB) - added by Tomohiro Ikai 7 years ago.

Download all attachments as: .zip

Change history (10)

comment:1 Changed 7 years ago by ksuehring

Split this report from #105

comment:2 Changed 7 years ago by ksuehring

Can you add more detail here, e.g. where exactly in the code the problem is? Or maybe suggest a patch?

For MV-HEVC we are constrained to two views, but in general I would prefer to keep the implementation open to potential new profiles. But the issue may also affect 3D-HEVC?

comment:3 Changed 7 years ago by dechang

  1. In HEVC MV-HEVC Spec, there isn't identicalMotion Codition check description found. I think this code implementation in HTM are used to save read data bandwidth in non-MV-HEVC mode, Because if this condition is correct, the L0 and L1 would be same and 1/2 average used for combination, so that the result would be same as L0 only. However, for MV-HEVC, L0 and L1 may come from the different view picture of the same POC, so the simplify process may have some issue. Anyway, they need your double confirm and clarify??
  1. Are MV-HEVC constrained to 2-views, Actually, in comformance streams, we found that 3-views sreams exists.
  1. I think the issue may also affect 3D-HEVC. But need you to double confirm item#1.

comment:4 Changed 7 years ago by Tomohiro Ikai

I think you are right.
The Identical motion checks whether the two reference pictures and MVs are identical or not. And the current HTM uses only POC to check the identicality of the pictures.
But as you point out, the 3D picture has two dimensions, POC and View. So in my understanding, we should check "ViewId" (or ViewOrderId ) as well as "POC" in HTM (Another way is by checking "layer id").

A patch is attached. We may use MVHEVCS_H.bit (IBP structure) for check (please #define NH_MV_FIX_TICKET_105 0 for the test. It can be seen disbling identical motion check changes the decoding picture of layer2 (MVHEVCS_H_2) )

By the way, Multiview main profile supports more than 2 views (up to 62 views or something). The plan of Multiview stereo profile had been removed thanks to
per layer profile/level signalling.

Note: it seems the issue may exist in SHM as well.

Changed 7 years ago by Tomohiro Ikai

comment:5 Changed 7 years ago by tech

Thanks for the patch. It seems to be fine for MV-HEVC. However, for 3D-HEVC the #elif branch is never reached, since NH_MV is always equal to 1 when NH_3D_ARP is equal to 1. A modified fix will be included in HTM-15.1.

comment:6 Changed 7 years ago by dechang

If that, does MV-HEVC conformance streams of 3 views also need to referesh, is that right??

comment:7 Changed 7 years ago by tech

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 7 years ago by Tomohiro Ikai

Thanks for ARP case fix.

And regarding comformance streams, this issue seems only affect MVHEVCS_H (3 views with IBP structure). But in my understanding, other streams also need to refresh due to other issues (especially TICKET100, OLS constraint for 2 layers, and PTL for non-additional OLS).

comment:9 Changed 7 years ago by dechang

Do you have any plan when we will refresh the conformance MV-HEVC streams? So that we can double check them.

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Owner, Subscriber, Participant

  • Derek Chang(Reporter, Participant)
  • Gerhard Tech(Owner, Subscriber, Participant, Always)
  • jct-3v@…(Subscriber)
  • Karsten Suehring(Participant, Always)
  • Tomohiro Ikai(Participant)